Dont work .htaccess redirect https to http and dont work ClipBucket in https


#1

Hi,
ClipBucket 2.7.6 dont work in https and the following correct rule htaccess dont work:

This should work for / (root) and all pages under / but not any subfolders.

RewriteEngine on
RewriteCond %{HTTP_HOST} domain\.com [NC]
RewriteCond %{HTTPS} on
RewriteRule ^([^/]+)?$ http://%{HTTP_HOST}/$1 [R=301,L]

If you put ^ in the second line, the rule will match only if the host is exactly domain.com and won’t match www.domain.com.

The absurd thing is that ClipBucket not work in https. If I try to visit https in the address, the page is destroyed, no graphics and impossible to navigate.

I also noticed that a visit links without SEO does not redirect url SEO (example: url not seo domain.com/video/watch_video.php?v=5728 not redirect to url seo domain.com/video/5728_this-url-seo).

Fix it, please
Best regards


#2

It sounds more like you are not properly set up for https connections.


#3

Yes it works on https

Have a look at https://www.trailersmania.com

What worked for me

1 - htaccess

RewriteEngine On
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://domain.com/$1 [L,R=301]

Header set Strict-Transport-Security “max-age=31536000” env=HTTPS

Header set X-XSS-Protection “1; mode=block”

2 - In your database table cb_config baseurl should start with https

About the url redirect I didn’t understand the problem

Let me know if the htpps solution I provide workrd for you


#4

Thanks for your answer.

This rule don’t work:

RewriteEngine on
RewriteCond %{HTTP_HOST} domain\.com [NC]
RewriteCond %{HTTPS} on
RewriteRule ^([^/]+)?$ http://%{HTTP_HOST}/$1 [R=301,L]

I want redirect https to http.


About the url redirects, here’s an example:

NOT URL SEO friendly:
http://forum.worldcomputing.it/forum/viewforum.php?f=3

URL SEO friendly
http://forum.worldcomputing.it/forum/informatica/

If I try to visit the url not seo (http://forum.worldcomputing.it/forum/viewforum.php?f=3), I get redirected to the url correctly seo (http://forum.worldcomputing.it/forum/informatica/).

On ClipBucket 2.7.6
If I visit the url not seo (domain.com/video/watch_video.php?v=5728), I dont get redirected to the url seo (domain.com/video/5728_this-url-seo).

This way takes a duplication of content and Google penalizes the site.


#5

https is working for me too from CB 2.6 and CB 2.7 too. https://eltuboadventista.com/mobile or https://eltuboadventista.com/7daytube or https://eltuboadventista.com/documentales


#6

Yes it works on https

Have a look at https://viveos.com


#7

Hi

Well from your first post I think you want to use https instead of http .
Don’t know what you trying to accomplished.
If you dont want https just install the CB the normal way, if you want your site to use https for the domain name (https://domain.com) and then redirect the video page to a non secure connection do a little google on it.A don’t think it is wise to do that and I am not aware of any advantage to SEO or Google.
If you want to the redirect the naked domain https://your.domain.com to https://www.your.domain.com you CAN’T do that with the htaccess - search this forum in HOW TO ADD WWW to your domain.

Now about the URL redirect I think you can set the type of SEO url on the Admin Area, then again and I don’t see any advantage on that .

I am using two CB 2.6 sites with this kind of URL domain.com/video/watch_video.php?v=5728 and all get indexed by google and other search engines.

The other two websites are

https://www.vituga.com
https://www.tugafado.com

Google them and you’ll see all the video files indexed.

Glad I helped you


#8

I HAD WRITTEN:

Thanks for your answer.

This rule don’t work:

RewriteEngine on
RewriteCond %{HTTP_HOST} domain.com [NC]
RewriteCond %{HTTPS} on
RewriteRule ^([^/]+)?$ http://%{HTTP_HOST}/$1 [R=301,L]
I want redirect https to http.

About the url redirects, here’s an example:

NOT URL SEO friendly:
http://forum.worldcomputing.it/forum/viewforum.php?f=3

URL SEO friendly
http://forum.worldcomputing.it/forum/informatica/

If I try to visit the url not seo ( http://forum.worldcomputing.it/forum/viewforum.php?f=3 ), I get redirected to the url correctly seo ( http://forum.worldcomputing.it/forum/informatica/ ).

On ClipBucket 2.7.6
If I visit the url not seo ( domain.com/video/watch_video.php?v=5728 ), I dont get redirected to the url seo ( domain.com/video/5728_this-url-seo ).

This way takes a duplication of content and Google penalizes the site.


Well, https works after a database change but I want to use http and set https to http redirect. I want to redirect from https to http but no one was able to help me.

IT REMAINS THE URL REWRITE BUG:

About the url redirects, here’s an example:

NOT URL SEO friendly:
http://forum.worldcomputing.it/forum/viewforum.php?f=3

URL SEO friendly
http://forum.worldcomputing.it/forum/informatica/

If I try to visit the url not seo ( http://forum.worldcomputing.it/forum/viewforum.php?f=3 ), I get redirected to the url correctly seo ( http://forum.worldcomputing.it/forum/informatica/ ).

On ClipBucket 2.7.6
If I visit the url not seo ( domain.com/video/watch_video.php?v=5728 ), I dont get redirected to the url seo ( domain.com/video/5728_this-url-seo ).

Considering that no one was able to give an answer which, once again renew my request. I want to redirect from https to http. Someone managed? How did he do? Or is another bug?


#9

if you want to use https
It’s very simple.
login to your cpanel or where you have installed phpMyAdmin
Search ClipBucket related table.
Then find the table called “cb_config”
where it says baseurl, click to edit,
you will see the name of your domain
For example mine was http://viveos.com
I edited this way https://viveos.com
It works for me very well.

in your .htaccess file you just put this,

RewriteEngine On
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://yourdomain.com/$1 [R,L]

And you not have to worry about the seo all links related to your script clipbucket, work on https


#10

I repeat. Your answer is useless.


I HAD WRITTEN:

Thanks for your answer.

This rule don’t work:

RewriteEngine on
RewriteCond %{HTTP_HOST} domain.com [NC]
RewriteCond %{HTTPS} on
RewriteRule ^([^/]+)?$ http://%{HTTP_HOST}/$1 [R=301,L]

I want redirect https to http.

About the url redirects bug, here’s an example:

NOT URL SEO friendly:
http://forum.worldcomputing.it/forum/viewforum.php?f=3

URL SEO friendly
http://forum.worldcomputing.it/forum/informatica/

If I try to visit the url not seo ( http://forum.worldcomputing.it/forum/viewforum.php?f=3 ), I get redirected to the url correctly seo ( http://forum.worldcomputing.it/forum/informatica/ ).

On ClipBucket 2.7.6
If I visit the url not seo ( domain.com/video/watch_video.php?v=5728 ), I dont get redirected to the url seo ( domain.com/video/5728_this-url-seo ).

This way takes a duplication of content and Google penalizes the site.

Well, https works after a database change but I want to use http and set https to http redirect. I want to redirect from https to http but no one was able to help me.

IT REMAINS THE URL REWRITE BUG:

About the url redirects bug, here’s an example:

NOT URL SEO friendly:
http://forum.worldcomputing.it/forum/viewforum.php?f=3

URL SEO friendly
http://forum.worldcomputing.it/forum/informatica/

If I try to visit the url not seo ( http://forum.worldcomputing.it/forum/viewforum.php?f=3 ), I get redirected to the url correctly seo ( http://forum.worldcomputing.it/forum/informatica/ ).

On ClipBucket 2.7.6
If I visit the url not seo ( domain.com/video/watch_video.php?v=5728 ), I dont get redirected to the url seo ( domain.com/video/5728_this-url-seo ).

Considering that no one was able to give an answer, once again renew my request. I want to redirect from https to http. Someone managed? How did he do? Or is another bug?


#11

The difference between http and https is that https requests are sent over an ssl-encrypted connection. The ssl-encrypted connection must be established between the browser and the server before the browser sends the http request.

Https requests are in fact http requests that are sent over an ssl encrypted connection. If the server rejects to establish an ssl encrypted connection then the browser will have no connection to send the request over. The browser and the server will have no way of talking to each other. The browser will not be able to send the url that it wants to access and the server will not be able to respond with a redirect to another url.

So this is not possible. If you want to respond to https links, then you need an ssl certificate.

For the benefit of anyone else trying to solve this.
In short, the catch all https -> http redirection that I was trying to achieve won’t work because the server is serving up the cert first which is then generating the security warning. This happens before the redirect for obvious security reasons, hence the redirect not working a I wanted.
Hope that helps somebody else.


#12

Hi again,
Pretty mess you got here.

Let’s see if I understood.

You have a server with a self signed certificate . This is not a valid cert in any browser.

You installed clipbucket with an IP that also is the IP for the server and has a self signed cert,Ok?!

Don’t know if it is your server or not.
If it was mine I would remove the self cert and install CB the normal way.

Now for the redirects from https to http here are some examples:

RewriteEngine On
RewriteCond %{HTTPS} on
RewriteRule (.*) http://%{HTTP_HOST}%{REQUEST_URI}

another

Options +FollowSymLinks
RewriteEngine On
RewriteCond %{ENV:HTTPS} on
RewriteRule (.*) http://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

or

RewriteCond %{HTTPS} =on
RewriteRule ^(.*)$ http://%{HTTP_HOST}/$1 [L,R=301]

One of them should work.

About the URL redirects:

If you want a URL like domain.com/video/5728_this-url-seo I think you should configure it on the admin area of CB


#13

Hi,
I have some questions to ask yourself:
how did you run the seo urls with https?
in the admin panel, just active https changes the font caracter and the size caracter becomes small. Also, the tab structure of the page in “Website configurations” is destroyed. How have you solved these problems?


#14

Hi,
I have indeed solve all the problems!
https doesn’t change any font size , caracter or anything else.

I think you are looking for problems not solutions.

Look at https:www.trailersmania.com everything looks ok and IS ok. On the admin_area ou have to also edit the global header to make it work with https.
Also other users post urls to their https sites and they are all working well.

If you want any more help please PM.


#15

I changed the base url in the database but I have 404 error if I try to watch a video and the panel control admin have problems in the character and structure of the page.

I changed the base url in the database, then what should I do to make it work like yours?

Thanks


#16

Hi
I think you better reinstall everything!
What’s the URl of your website?


#17

Hi,
the definitive solution:
RewriteEngine On
RewriteCond %{HTTPS} on
RewriteRule (.*) http://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]