Video conversing stuck


#1

I have checked all requirements and paths all is ok.
http://clip-bucket.com/cb-install-requirements/
I can convert video over terminal, but in clipbucket is stuck on processing.

here is log.
Converion Log for file .

Reading Conversion log for file 

Conversion details

Raw Conversion Log

==========================================

Pre-Check Configurations

==========================================

File to be converted

	Initializing File 1473605648b0fbf.mp4 and pre checking configurations...

Temporary Uploading

	File Uploaded to Temp directory successfully and video conversion file is being executed !

Video Conversion File Execution

	Video Converson File executed successfully with Target File > !1473605648b0fbf.mp4

#2

So nobody can’t help me with conversion problem???


#3

that is not enough info for me to help, what about the conversion log?


#4

I just have converted a small test video in terminal with
ffmpeg -i yourvideoname.mp4 -c:v libx264 outputfilename.wmv
video successfully converted and ti works, belov are results.
In clipbucket doesn’t work.

ffmpeg version 2.8.7 Copyright © 2000-2016 the FFmpeg developers
built with gcc 4.8.5 (GCC) 20150623 (Red Hat 4.8.5-4)
configuration: --prefix=/usr --bindir=/usr/bin --datadir=/usr/share/ffmpeg --incdir=/usr/include/ffmpeg --libdir=/usr/lib64 --mandir=/usr/share/man --arch=x86_64 --optflags=’-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -m64 -mtune=generic’ --enable-bzlib --disable-crystalhd --enable-gnutls --enable-ladspa --enable-libass --enable-libcdio --enable-libdc1394 --disable-indev=jack --enable-libfreetype --enable-libgsm --enable-libmp3lame --enable-openal --enable-libopenjpeg --enable-libopus --enable-libpulse --enable-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libvorbis --enable-libv4l2 --enable-libx264 --enable-libx265 --enable-libxvid --enable-x11grab --enable-avfilter --enable-avresample --enable-postproc --enable-pthreads --disable-static --enable-shared --enable-gpl --disable-debug --disable-stripping --shlibdir=/usr/lib64 --enable-runtime-cpudetect
libavutil 54. 31.100 / 54. 31.100
libavcodec 56. 60.100 / 56. 60.100
libavformat 56. 40.101 / 56. 40.101
libavdevice 56. 4.100 / 56. 4.100
libavfilter 5. 40.101 / 5. 40.101
libavresample 2. 1. 0 / 2. 1. 0
libswscale 3. 1.101 / 3. 1.101
libswresample 1. 2.101 / 1. 2.101
libpostproc 53. 3.100 / 53. 3.100
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from ‘small.mp4’:
Metadata:
major_brand : mp42
minor_version : 0
compatible_brands: mp42isomavc1
creation_time : 2010-03-20 21:29:11
encoder : HandBrake 0.9.4 2009112300
Duration: 00:00:05.57, start: 0.000000, bitrate: 551 kb/s
Stream #0:0(und): Video: h264 (Constrained Baseline) (avc1 / 0x31637661), yuv420p(tv, bt709), 560x320, 465 kb/s, 30 fps, 30 tbr, 90k tbn, 60 tbc (default)
Metadata:
creation_time : 2010-03-20 21:29:11
encoder : JVT/AVC Coding
Stream #0:1(eng): Audio: aac (LC) (mp4a / 0x6134706D), 48000 Hz, mono, fltp, 83 kb/s (default)
Metadata:
creation_time : 2010-03-20 21:29:11
[libx264 @ 0x1aeeb60] using cpu capabilities: MMX2 SSE2Fast LZCNT
[libx264 @ 0x1aeeb60] profile High, level 3.0
[libx264 @ 0x1aeeb60] 264 - core 148 r2643 5c65704 - H.264/MPEG-4 AVC codec - Copyleft 2003-2015 - http://www.videolan.org/x264.html - options: cabac=1 ref=3 deblock=1:0:0 analyse=0x3:0x113 me=hex subme=7 psy=1 psy_rd=1.00:0.00 mixed_ref=1 me_range=16 chroma_me=1 trellis=1 8x8dct=1 cqm=0 deadzone=21,11 fast_pskip=1 chroma_qp_offset=-2 threads=9 lookahead_threads=1 sliced_threads=0 nr=0 decimate=1 interlaced=0 bluray_compat=0 constrained_intra=0 bframes=3 b_pyramid=2 b_adapt=1 b_bias=0 direct=1 weightb=1 open_gop=0 weightp=2 keyint=250 keyint_min=25 scenecut=40 intra_refresh=0 rc_lookahead=40 rc=crf mbtree=1 crf=23.0 qcomp=0.60 qpmin=0 qpmax=69 qpstep=4 ip_ratio=1.40 aq=1:1.00
Output #0, asf, to ‘outputfilename.wmv’:
Metadata:
major_brand : mp42
minor_version : 0
compatible_brands: mp42isomavc1
WM/EncodingSettings: Lavf56.40.101
Stream #0:0(und): Video: h264 (libx264) (H264 / 0x34363248), yuv420p, 560x320, q=-1–1, 30 fps, 1k tbn, 30 tbc (default)
Metadata:
creation_time : 2010-03-20 21:29:11
encoder : Lavc56.60.100 libx264
Stream #0:1(eng): Audio: wmav2 (a[1][0][0] / 0x0161), 48000 Hz, mono, fltp, 128 kb/s (default)
Metadata:
creation_time : 2010-03-20 21:29:11
encoder : Lavc56.60.100 wmav2
Stream mapping:
Stream #0:0 -> #0:0 (h264 (native) -> h264 (libx264))
Stream #0:1 -> #0:1 (aac (native) -> wmav2 (native))
Press [q] to stop, [?] for help
frame= 166 fps=0.0 q=-1.0 Lsize= 245kB time=00:00:05.52 bitrate= 362.8kbits/s
video:140kB audio:87kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: 7.904856%
[libx264 @ 0x1aeeb60] frame I:1 Avg QP:21.26 size: 18012
[libx264 @ 0x1aeeb60] frame P:46 Avg QP:21.81 size: 1895
[libx264 @ 0x1aeeb60] frame B:119 Avg QP:26.12 size: 317
[libx264 @ 0x1aeeb60] consecutive B-frames: 3.0% 0.0% 12.7% 84.3%
[libx264 @ 0x1aeeb60] mb I I16…4: 50.7% 12.3% 37.0%
[libx264 @ 0x1aeeb60] mb P I16…4: 1.5% 0.4% 0.1% P16…4: 41.8% 8.2% 5.8% 0.0% 0.0% skip:42.1%
[libx264 @ 0x1aeeb60] mb B I16…4: 0.1% 0.1% 0.0% B16…8: 22.5% 1.5% 0.2% direct: 0.5% skip:75.1% L0:45.5% L1:52.1% BI: 2.4%
[libx264 @ 0x1aeeb60] 8x8 transform intra:18.0% inter:57.1%
[libx264 @ 0x1aeeb60] coded y,uvDC,uvAC intra: 31.5% 69.5% 35.5% inter: 3.1% 10.2% 1.6%
[libx264 @ 0x1aeeb60] i16 v,h,dc,p: 1% 30% 2% 68%
[libx264 @ 0x1aeeb60] i8 v,h,dc,ddl,ddr,vr,hd,vl,hu: 8% 39% 17% 3% 6% 4% 13% 3% 7%
[libx264 @ 0x1aeeb60] i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 15% 29% 14% 4% 8% 7% 12% 4% 8%
[libx264 @ 0x1aeeb60] i8c dc,h,v,p: 47% 37% 10% 7%
[libx264 @ 0x1aeeb60] Weighted P-Frames: Y:0.0% UV:0.0%
[libx264 @ 0x1aeeb60] ref P L0: 63.0% 3.8% 20.7% 12.5%
[libx264 @ 0x1aeeb60] ref B L0: 81.5% 13.4% 5.2%
[libx264 @ 0x1aeeb60] ref B L1: 92.2% 7.8%
[libx264 @ 0x1aeeb60] kb/s:206.59

Here is conversion log from clipbucket again. And it is failed

Converion Log for file .

Reading Conversion log for file
Conversion details
Raw Conversion Log

Temporary Uploading

File Uploaded to Temp directory successfully and video conversion file is being executed !

Video Conversion File Execution

Video Converson File executed successfully with Target File > !14738501103f966.mp4

==========================================
Starting Conversion Log

Getting Arguments

Filename : 14738501103f966.mp4
File directory : 2016/09/14
Log file : /var/www/clipbucket/files/logs/2016/09/14/14738501103f966.log

Conversion queue

Getting the file information from the queue for conversion

Conversion queue

File has been moved from Temporary dir to Conversion Queue

Parsing FFmpeg Configurations

use_video_rate : 1
use_video_bit_rate : 1
use_audio_rate : 1
use_audio_bit_rate : 1
use_audio_codec : 1
use_video_codec : 1
format : mp4
video_codec : libx264
audio_codec : aac-strict -2
audio_rate : 22050
audio_bitrate : 128000
video_rate : 25
video_bitrate : 512000
video_bitrate_hd :
normal_res :
high_res :
max_video_duration : 360
resize : max
outputPath : 2016/09/14/
cb_combo_res : no
gen_240 : yes
gen_360 : yes
gen_480 : yes
gen_720 :
gen_1080 :

Starting Conversion

Started on 2016-09-14 10:49:02 - 2016 Sep 14

Checking File…
File : /var/www/clipbucket/files/conversion_queue/14738501103f966.mp4

File Exists

Yes

Preparing file…

format : mov,mp4,m4a,3gp,3g2,mj2
duration : 148.24
size : 6378701
bitrate : 344248
video_width : 640
video_height : 360
video_wh_ratio : 1.7777777777778
video_codec : h264
video_rate : 29.97002997003
video_bitrate : 245645
video_color : N/A
audio_codec : aac
audio_bitrate : 96024
audio_rate : 44100
audio_channels : 2
path : /var/www/clipbucket/files/conversion_queue/14738501103f966.mp4
rotation : 0

Thumbs Generation

Starting

Thumbs Files

File : /var/www/clipbucket/files/thumbs/2016/09/14/14738501103f966-original-1.jpg
File : /var/www/clipbucket/files/thumbs/2016/09/14/14738501103f966-original-2.jpg
File : /var/www/clipbucket/files/thumbs/2016/09/14/14738501103f966-original-3.jpg
File : /var/www/clipbucket/files/thumbs/2016/09/14/14738501103f966-original-4.jpg
File : /var/www/clipbucket/files/thumbs/2016/09/14/14738501103f966-original-5.jpg
File : /var/www/clipbucket/files/thumbs/2016/09/14/14738501103f966-168x105-1.jpg
File : /var/www/clipbucket/files/thumbs/2016/09/14/14738501103f966-168x105-2.jpg
File : /var/www/clipbucket/files/thumbs/2016/09/14/14738501103f966-168x105-3.jpg
File : /var/www/clipbucket/files/thumbs/2016/09/14/14738501103f966-168x105-4.jpg
File : /var/www/clipbucket/files/thumbs/2016/09/14/14738501103f966-168x105-5.jpg
File : /var/www/clipbucket/files/thumbs/2016/09/14/14738501103f966-416x260-1.jpg
File : /var/www/clipbucket/files/thumbs/2016/09/14/14738501103f966-416x260-2.jpg
File : /var/www/clipbucket/files/thumbs/2016/09/14/14738501103f966-416x260-3.jpg
File : /var/www/clipbucket/files/thumbs/2016/09/14/14738501103f966-416x260-4.jpg
File : /var/www/clipbucket/files/thumbs/2016/09/14/14738501103f966-416x260-5.jpg
File : /var/www/clipbucket/files/thumbs/2016/09/14/14738501103f966-632x395-1.jpg
File : /var/www/clipbucket/files/thumbs/2016/09/14/14738501103f966-632x395-2.jpg
File : /var/www/clipbucket/files/thumbs/2016/09/14/14738501103f966-632x395-3.jpg
File : /var/www/clipbucket/files/thumbs/2016/09/14/14738501103f966-632x395-4.jpg
File : /var/www/clipbucket/files/thumbs/2016/09/14/14738501103f966-632x395-5.jpg
File : /var/www/clipbucket/files/thumbs/2016/09/14/14738501103f966-768x432-1.jpg
File : /var/www/clipbucket/files/thumbs/2016/09/14/14738501103f966-768x432-2.jpg
File : /var/www/clipbucket/files/thumbs/2016/09/14/14738501103f966-768x432-3.jpg
File : /var/www/clipbucket/files/thumbs/2016/09/14/14738501103f966-768x432-4.jpg
File : /var/www/clipbucket/files/thumbs/2016/09/14/14738501103f966-768x432-5.jpg
====== End : Thumbs Generation =======

Conversion Completed

Time Took : 1.8473 seconds

conversion_status : failed


#5

it seems that your missing aac codec,

run the command ffmpeg and post the result here


#6

ffmpeg
FFmpeg version 0.5, Copyright © 2000-2009 Fabrice Bellard, et al.
configuration:
libavutil 49.15. 0 / 49.15. 0
libavcodec 52.20. 0 / 52.20. 0
libavformat 52.31. 0 / 52.31. 0
libavdevice 52. 1. 0 / 52. 1. 0
built on Sep 15 2016 15:05:14, gcc: 4.8.5 20150623 (Red Hat 4.8.5-4)

I have installed ffmpeg by this instructions
https://trac.ffmpeg.org/wiki/CompilationGuide/Centos


#7

use our installer


#8

Thank you. Now works ok!